Come risolvere l'errore couldn't locate lint-gradle-api-26.1.2.jar in Flutter

Come risolvere l'errore couldn't locate lint-gradle-api-26.1.2.jar in Flutter

Seguendo tutte le linee guida ufficiali, ho installato Flutter in maniera molto veloce.

Peccato che dopo aver avviato la app mi usciva questo errore:

couldn't locate lint-gradle-api-26.1.2.jar

In verità risolvere è molto semplice.

Andate nella directory dove avete scaricato il Flutter SDK, e poi in packages-flutter_tools-gradle.

Qui avete il file flutter.gradle che dovete modificare da cosi:

buildscript {
    repositories {
		jcenter()
        maven {
            url 'https://dl.google.com/dl/android/maven2'
        }
    }
    dependencies {
        classpath 'com.android.tools.build:gradle:3.1.2'
    }
}

A così:

buildscript {
    repositories {
        maven {
            url 'https://dl.google.com/dl/android/maven2'
        }
		jcenter()
    }
    dependencies {
        classpath 'com.android.tools.build:gradle:3.1.2'
    }
}

In pratica dovete spostare una riga.

A questo punto riavviate la app.

Enjoy!




Share

Commentami!

About Mattepuffo.com

Blog dedicato all'informatica e alla programmazione!
Tutti i contenuti di questo blog, tranne casi particolari, sono sotto licenza Licenza Creative Commons Creative Commons Attribution-Noncommercial-Share Alike 2.5. .

2576 articoli
310 commenti
19 progetti
Altri link
  • About
  • Scrivimi
  • Copyright
  • Sitemap
  • matteo.ferrone@yahoo.it
  • GitHub
  • Privacy Policy