Home / Sistemi operativi & mobile / Linux / Come risolvere l'errore Failed to build gem native extension su Linux
Mattepuffo

Come risolvere l'errore Failed to build gem native extension su Linux

Come risolvere l'errore Failed to build gem native extension su Linux

Tempo fa stavo giocherellando con Ruby per installare alcune estensioni con GEM.

In sostanza mi compariva questo errore:

ERROR:  Error installing compass:
ERROR: Failed to build gem native extension.

Ho scoperto che la soluzione è molto semplice, in quanto basta installare un ulteriore pacchetto.

Se siamo su Debian:

# aptitude install ruby-dev

Questo dovrebbe bastare.

Enjoy!