Home / Sistemi operativi & mobile / Android / This Android SDK requires version
Mattepuffo

This Android SDK requires version

This Android SDK requires version

Quanti di voi sono incappati nel classico errore "This Android SDK requires version..." provando a sviluppare per Android?

Mi sa tanti, io compreso ovviamente.

E, anche se mi duole dirlo, soprattutto da quando uso Netbeans invece di Eclipse per programmare su Anrdoid.

Esistono varie soluzioni a questo problema, anche se alla fine tutte si riducono all'aggiornamento del plugin ADT.

Quindi ad esempio, su Eclipse andate su Help -> Check for Updates.

Questo aprirà la finestra di dialogo per l'aggiornamento, e cercherà tutti i vari aggiornamenti disponibili.

Tra le voci disponibili, selezionate Android DDMS e Android Development Tools.

Accettate le licenze e aggiornate.

Alla fine riavviate Eclipse.

Se usate un altro IDE, dovete fare praticamente la stessa cosa, usando gli strumenti offerti dal programma che state usando.

Enjoy!